Featured Post

Variable Sized Arrays Discussions | C++ | HackerRank Variable Length Arrays in C and C++ - GeeksforGeeks

Variable Sized Arrays Variable Sized Arrays Discussions | C++ | HackerRank Consider an  -element array,  , where each index   in the array c...

Saturday, April 3, 2021

Printing Tokens Discussions | C | HackerRank Hacker Rank Solutions: Printing Tokens






Given a sentence, , print each word of the sentence in a new line.

Input Format

The first and only line contains a sentence, .

Constraints

Output Format

Print each word of the sentence in a new line.

Sample Input 0

This is C 

Sample Output 0

This
is
C

Explanation 0

In the given string, there are three words ["This", "is", "C"]. We have to print each of these words in a new line.

Sample Input 1

Learning C is fun

Sample Output 1

Learning
C
is
fun

Sample Input 2

How is that

Sample Output 2

How
is
that


#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
int main()
 {
    char *s;
    s = malloc(1024 * sizeof(char));
    scanf("%[^\n]", s);
    s = (realloc(s, strlen(s) + 1));
    int l =strlen(s);
    //Write your logic to print the tokens of the sentence here.
    
    for(int i=0;i<l;i++)
     {  if(s[i] == ' ')
         {   printf("\n");
         }
        else
         printf("%c",s[i]);
    }
    return 0;
} 




Related searches

No comments:

Post a Comment